mercredi 4 janvier 2017

Le jour d'après MacBook

Le mois dernier, j'avais annoncé ma décision de remplacer mon Mac Book Pro par un laptop Linux. L'article avait suscité pas mal de réactions, ce qui me fait penser que je ne suis pas le seul à vouloir faire ça. Depuis, j'ai commandé et reçu un Dell Precision 5510.

Après avoir installé, configuré et testé ma nouvelle machine, je voulais raconter mes premières semaines. Si vous ne voulez pas lire la suite, je résume : ça s'est parfaitement bien passé. Mais en fait pas tout à fait.

Pourquoi un Precision 5510 ?

Je dois avouer que j'étais perdu face au large choix de laptops. Il y a pas mal de marques qui ont des catalogues indigestes et difficiles à comparer.

Ensuite, j'ai eu pas mal de bon retours de clients de Dell. Et surtout, ils proposent quelques laptops en Linux.

Donc Dell.

La gamme à la mode est celle des XPS. Fins, légers, puissants : ça colle bien pour remplacer un MBP. Malheureusement, seul le XPS 13, avec un écran 13" est proposé avec Linux, le XPS 15 n'est qu'en Windows. Pas grave, le Precision 5510 lui ressemble beaucoup à un prix similaire, et avec de bonnes possibilités de personnalisation.


Donc Precision 5510.


Coté personnalisation, j'ai choisi les caractéristiques suivantes : écran 15.6" en 1920x1080, processeur i7-6820HQ, 32 Go de mémoire, SSD m.2 512 Go. Pour un prix de 2800 €. OK, c'est cher. Presque autant qu'un Mac. C'est quand même mon outil de travail pour les 3 à 5 années qui viennent, et j'espère qu'il tiendra la route sur la durée.

La commande

Le site de Dell m'a bien énervé. Il a une ergonomie digne des années 2000.

Et coté délai, on passe de celui d'expédition (3 à 4 jours) avant la commande, à celui de livraison (2 semaines) une fois la commande passée.
Enfin, le suivi du colis du livreur était nul. Comme je risquais d'être absent à la date de livraison, je m'étais abonné au suivi pour pouvoir modifier la date de livraison finale. Problème, le suivi n'a que deux états : "Parti de Chine" et "Livré chez vous".

Bon, tout ça n'est pas grave, j'ai mon nouveau jouet.

L'installation

Le laptop est livré avec Ubuntu 14.04, avec des dépôts spécifiques à Dell, pour avoir les bons drivers. Au premier démarrage, il finalise l'installation.


Première erreur de ma part, j'ai sélectionné le français comme langue d'installation. Ça ne marche tout simplement pas, on a le choix entre plusieurs dizaines de langues, mais il faut choisir l'anglais.

Une fois l'obstacle de la langue franchi, l'installation se passe bien. Au bout de quelques minutes j'ai un laptop qui fonctionne parfaitement.

J'ai particulièrement testé les points suivants : Wi-Fi, Ethernet, Bluetooth, son (haut-parleurs, sortie Jack, micro), sortie vidéo HDMI, Webcam et mise en veille.

Les cris et les pleurs

Tout est OK jusqu'au premier update.

Un plantage en plein update, suivi de quelques tentatives pour le récupérer et le mener au bout... Le système fonctionne, mais le Wi-Fi est HS.


Visiblement, je ne suis pas le seul. En parcourant les forums, d'autres on eu des problèmes de wifi, et la solution la plus simple semble être un upgrade vers Ubuntu 16.04.

Bingo !, le Wi-Fi fonctionne à nouveau...
... mais pas les haut-parleur, ni la sortie jack, ni la webcam, ni le micro intégré.

Tout va bien...

Après quelques heures de tentatives infructueuses, je décide de repartir de zéro et de faire une réinitialisation usine.

C'était la bonne décision : réinstallation d'Ubuntu 14.04 puis mise à jour, tout va bien. Mais comme ce n'est pas parce que tout va bien qu'il ne faut rien changer, je fais l'upgrade vers Ubuntu 16.04.

Là aussi, tout va bien, mais je ne m'en rends pas compte tout de suite.

... ou presque

En Ubuntu 16.04, tout fonctionne sauf la Webcam et le micro intégré. En réalité, il y a surtout un problème avec les applications par défaut.

Webcam digitale
Pour la Webcam, un bug dans l'application Camera, utilisée par défaut, est la cause du dysfonctionnement. En installant une autre application, comme Cheese, ça fonctionne.

Et pour le micro, c'est à peut prêt la même chose, au lieu de l'application Sound, il faut utiliser PulseAudio Volume Control.

Donc, contrairement aux apparences, tout fonctionne.

Collection d'adaptateurs

Comme sur tout laptop moderne, il faut renouveler sa collection d'adaptateurs.

Pour le réseau, l'adaptateur USB-C / RJ-45 est fourni et fonctionne bien.

Pour la vidéo, il y a une prise HDMI. J'ai commandé aussi un adaptateur USB-C / VGA et ai pu tester un HDMI / VGA. Aucun problème, la sortie vidéo a marché au premier essai avec mon vidéo-projecteur.

Il me reste à espérer que ça marche aussi bien chez les clients qui n'auront pas de HDMI.

Pourvu que ça dure

Donc tout va bien, malgré quelques frayeurs. Je n'ai pas eu besoin de faire de grosse bidouille ou de recompiler le noyau.

Pour l'instant je suis satisfait de mon achat.